Trading Is Down On Some Coins
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted Mar 16, 2024 - 20:54 PDT
Investigating
MTL/XPR and MTL/BTC pairs are undergoing maintenance. Trading will resume on these pairs when the maintenance is complete. We understand the inconvenience it may cause and are working swiftly to resolve it.

We'll keep you posted with any developments. Thank you for your cooperation and ongoing support.
Posted Mar 16, 2024 - 13:25 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)) and Cryptocurrency Services (Transactions).