The issue has been identified and a fix is being implemented.
Posted Jul 24, 2025 - 14:00 PDT
Investigating
We are currently experiencing an issue that is preventing some users from fully upgrading their accounts. Our team is actively investigating the cause and working on a solution.
Thank you for your patience and understanding while we resolve this.
Posted Jul 24, 2025 - 12:53 PDT
This incident affected: Infrastructure (Backend Services).