Hedera Mainnet Upgrade - Delay on Deposits and Withdrawals of HBAR
Incident Report for Metal Pay
Resolved
The scheduled maintenance has been completed.
Posted Jul 17, 2024 - 10:17 PDT
Identified
Due to the Hedera Mainnet Blockchain upgrade, crypto withdrawals and deposits for HBAR will be delayed on Wednesday, July 17th, 2024 at 17:00 UTC for approximately 60 minutes.
Posted Jul 17, 2024 - 08:04 PDT
This incident affected: Cryptocurrency Services (Deposits, Withdrawals).