Error getting payment quote issue

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted May 12, 2025 - 07:32 PDT

Investigating

We are currently experiencing an issue with getting payment quotes on the Metal Pay app. This issue may impact and delay crypto deposits and withdrawals. Our team is actively working on resolving this. Thank you for your patience.
Posted May 12, 2025 - 06:23 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)) and Cryptocurrency Services (Deposits, Withdrawals).