Metal Pay App Loading Issue
Incident Report for Metal Pay
Resolved
The login issue for Android users has been also fixed. There's no need to update your app—everything should now be working normally. Thank you for your patience and understanding!
Posted Oct 21, 2024 - 12:32 PDT
Monitoring
We’ve just released a new version of the Metal Pay app for iOS users! This update includes a fix for the recent login issue. Please update your app to the latest version for a smoother experience.

For Android users, we’re working hard on the update, and it will be available soon. Thank you for your patience!
Posted Oct 20, 2024 - 22:07 PDT
Investigating
We are currently experiencing an issue with the Metal Pay app not loading properly. Our technical team is actively working to resolve the problem as quickly as possible. We appreciate your patience and will provide updates as soon as we have more information.

Thank you for your understanding!
Posted Oct 20, 2024 - 07:23 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)).