Users having issues withdrawing over Proton network

Incident Report for Metal Pay

Resolved

Our technical team has resolved the issue. We appreciate your understanding and patience.
Posted Mar 03, 2023 - 11:46 PST

Investigating

We have identified that some users experienced problems withdrawing cryptos over Proton network on the Metal Pay app. Our team is working to fix it. Thank you for your understanding and patience.
Posted Mar 03, 2023 - 05:38 PST
This incident affected: Cryptocurrency Services (Withdrawals).