Market Order Service Disruption

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 12:56 PST

Investigating

Market orders on the Metal Pay app are currently experiencing a temporary issue. Our technical team is actively investigating and working on a resolution.
Please note that all other operations remain fully functional. Thank you for your patience and understanding.
Posted Jan 31, 2026 - 13:17 PST
This incident affected: Fiat Currency Services (Market Orders).