Crypto Withdrawal Delays on Metal Pay
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted Aug 16, 2024 - 14:01 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2024 - 13:32 PDT
Investigating
We are currently experiencing a delay in processing crypto withdrawals on Metal Pay, as they remain in transit status. Our team is actively working to resolve this issue as quickly as possible. We appreciate your patience and will provide updates as soon as the situation is resolved.
Posted Aug 16, 2024 - 12:00 PDT
This incident affected: Cryptocurrency Services (Withdrawals).