Transactions Processing Delays
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 19:38 PDT
Investigating
We have identified an issue with processing transactions. Our team is actively investigating the issue and working on a fix. Thank you for your understanding and patience.
Posted Apr 15, 2024 - 19:02 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)), Cryptocurrency Services (Deposits, Transactions, Withdrawals), and Fiat Currency Services (Deposits, Transactions, Withdrawals).