Metal Pay Login Issues

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted May 05, 2025 - 21:07 PDT

Investigating

We are currently investigating reports from users experiencing problems logging into the Metal Pay app. Our team is working to identify the cause and will provide updates as we learn more. Thank you for your patience.
Posted May 05, 2025 - 20:52 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)).