Our technical team has identified the issue. Please note that there may be delays in processing deposits to your account as well. We're actively working to resolve this as quickly as possible.
Posted Aug 21, 2025 - 12:07 PDT
Investigating
We are currently experiencing delays in processing withdrawals from Metal Pay. Our team is actively working to resolve the issue as quickly as possible. We appreciate your patience and understanding.
Posted Aug 21, 2025 - 11:31 PDT
This incident affected: Cryptocurrency Services (Deposits, Withdrawals).