Account Verification Issues and Transaction Delays
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 22:20 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2024 - 19:22 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 04, 2024 - 19:22 PDT
Identified
We have identified an issue with our account verification system which may also affect transactions.

The issue is being investigated at this time. We appreciate your patience and understanding.
Posted Apr 04, 2024 - 15:45 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)), Cryptocurrency Services (Deposits, Transactions, Withdrawals, Transaction Nodes), and Fiat Currency Services (Deposits, Transactions, Withdrawals).