Transaction related issues impacting Illinois, Kansas and US Virgin Islands customers
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted May 20, 2022 - 13:48 PDT
Identified
We have identified an issue that is impacting Fiat Transactions for residents of Illinois, Kansas, and US Virgin Islands. We are working on a resolution, and expect service to return to normal within 12-24 hours.
Posted May 19, 2022 - 13:33 PDT
This incident affected: Fiat Currency Services (Deposits, Transactions, Withdrawals).