Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 03, 2025 - 12:00 PDT
Scheduled
This is routine scheduled maintenance to upgrade our systems with increased performance. We estimate the app will remain in maintenance mode for less than 15 minutes, and we will ensure the maintenance window is as short as possible.
During the maintenance window: - The app might be offline, and trading might not be available.
We will notify you when the upgrade is complete and all services are back online.
Posted Sep 02, 2025 - 21:40 PDT
This scheduled maintenance affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)).