Metal Pay App Connection Issues

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 00:00 PDT

Update

The issue has been resolved for Android users. Please update your Metal Pay app to the latest version available on the Google Play Store.

For iOS users, a new version of the Metal Pay app will be available soon. We will notify you as soon as it is ready for download.
Posted Jul 30, 2026 - 16:23 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 30, 2026 - 13:03 PDT

Investigating

We are currently investigating connection issues that may prevent some users from loading or accessing the Metal Pay app. Our team is working to resolve the issue as soon as possible. We appreciate your patience.
Posted Jul 29, 2026 - 13:13 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)).