Temporary Trading Issue with Certain Pairs
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted Dec 10, 2024 - 00:19 PST
Investigating
We are currently experiencing temporary issues with specific trading pairs, including AVAX, EOS, and XRP.

Our technical team is diligently working to resolve this matter. We appreciate your patience and understanding during this time.
Posted Nov 27, 2024 - 11:49 PST
This incident affected: Cryptocurrency Services (Transactions).