Crypto Transaction Delays and Deposit/Withdrawal Errors
Incident Report for Metal Pay
Resolved
Crypto deposits and withdrawals are functioning.
Posted Nov 21, 2024 - 08:13 PST
Investigating
We are currently investigating an issue with crypto transaction delays.
Posted Nov 21, 2024 - 04:21 PST
This incident affected: Cryptocurrency Services (Deposits, Withdrawals).