ADA Maintenance – Deposits & Withdrawals Paused

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 10:46 PDT

Investigating

ADA deposits and withdrawals are temporarily paused due to scheduled maintenance. We’ll restore full functionality as soon as the work is complete.
Posted Apr 30, 2025 - 15:27 PDT
This incident affected: Cryptocurrency Services (Deposits, Withdrawals).