Intermittent delays with outgoing transactions
Incident Report for Metal Pay
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 13:48 PST
Investigating
Our transaction processing infrastructure is currently experiencing an issue causing a delay in finalizing the transaction status.
Posted Feb 20, 2024 - 11:56 PST
This incident affected: Cryptocurrency Services (Deposits, Transactions, Withdrawals) and Fiat Currency Services (Deposits, Transactions, Withdrawals).