Live Price Display Issue on Metal Pay App

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 11:00 PDT

Investigating

We are aware that live prices on the Metal Pay app are currently not updating. Our technical team is actively working to resolve the issue.

We sincerely appreciate your patience and understanding as we work towards a fix.
Posted Mar 19, 2025 - 10:14 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)) and Infrastructure (Backend Services).