Metal Pay Transaction Delays

Incident Report for Metal Pay

Resolved

Thank you for your patience and understanding while our team investigated and worked to resolve this issue.

All features and services are now fully enabled and operational.

If you experience any issues or have any questions, please feel free to reach out to our Client Services team. We’re here to help. Thank you again for your patience and continued support.
Posted Sep 18, 2026 - 14:52 PDT

Update

Our team continues to make progress on the final steps required to fully restore crypto deposits and withdrawals. All other services remain operational, and user accounts and funds remain safe and secure.

We are now in the final stages of the restoration process and expect to complete the remaining work very soon. Pending deposit and withdrawal transactions will be processed once services are fully restored, and there is no need to resubmit any existing requests.

We appreciate your continued patience and understanding while we complete this work. We will provide another update as soon as crypto deposits and withdrawals are fully restored.
Posted Sep 17, 2026 - 10:23 PDT

Update

Thank you for your continued patience while we worked to resolve the issue. All services are now operational, with the exception of crypto withdrawals. Pending and new crypto withdrawal requests will be processed/fully enabled very soon. We appreciate your additional patience and understanding as we complete this final step.

Please continue to follow our Status Page for the latest updates, and contact our Client Services team if you have any questions or need further assistance.
Posted Sep 15, 2026 - 11:52 PDT

Identified

The team is actively working to resolve the ongoing investigation, which will allow us to process pending transactions very soon. Please refer to the Status Page for future updates, and feel free to contact the Client Services team if you have any further questions or inquiries.

Thank you for your patience.
Posted Sep 14, 2026 - 11:07 PDT

Investigating

We are currently investigating reports of transaction issues affecting some users on Metal Pay.

User accounts and funds remain safe and secure. Our team is actively working to resolve the issue and will provide further updates as more information becomes available.

Thank you for your patience.
Posted Sep 12, 2026 - 14:44 PDT
This incident affected: Cryptocurrency Services (Deposits, Withdrawals).